Internet Browser Compatibility

Please ensure your browsers are up to date and that your versions comply with the version guidelines shown below. Customers booking a flight on our website using older browser versions after the 30th of March 2017 will get an error message and their access will be denied.

Google Chrome: Version 33 & above
Mozilla Firefox: Version 32 & above
Microsoft IE: Version 11 (v10: TLS 1.2 manually has to be enabled)
Microsoft Edge: Version 13 & above
Opera: Version 17 & above
Safari: Version 7 & later

We've reserved a
seat for you!

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form